Ability to set RenderBin on osgEarth::MapNode

classic Classic list List threaded Threaded
1 message Options
Blanky Blanky
Reply | Threaded
Open this post in threaded view
|

Ability to set RenderBin on osgEarth::MapNode

Hello,

I was trying to set the RenderOrder on the osg::StateSet for an osgEarth::MapNode. I tried the MapNode itself and its TerrainEngineNode, but neither seemed to have an effect. Is there something else I should be doing this with?

My problem is that I use a DepthOffsetGroup for mitigating z-fighting - which perfectly works by the way and we appreciate the ease of use of it - but there is still occulting/clipping with the MapNode for things that have an altitude of 0.0 and a height such that half of the object is invisible under the ground, instead of rendering on top of it. I also noticed this seems to be more of an issue an a Projected Map, and the WGS-84 map seems to appear fine.

I used to use osg::Depth but deprecated it because of its horrid z-fighting with some many things being at height 0.0. It had the effect that I was looking for though, but was trying to mimic that behavior with a combination of RenderBin orders and the DepthOffsetGroup.

Thanks for any input on which node or setting I can apply for my desired behavior (Allowing a MapNode to render beind everything else, even though everything is added as a child to it).

- Blanky