CMake configure error on Mac OSX 10.5.6

classic Classic list List threaded Threaded
6 messages Options
G-Bivins G-Bivins
Reply | Threaded
Open this post in threaded view
|

CMake configure error on Mac OSX 10.5.6

Hi Glenn,
I tried to build this on Mac OSX 10.5.6 and the cmake fails with the following errors:

   Found Threads: TRUE
   CMake Error at CMakeModules/ModuleInstall.cmake:38 (INSTALL):
       install TARGETS given no LIBRARY DESTINATION for shared library target
     "osgEarth".
   Call Stack (most recent call first):
      src/osgEarth/CMakeLists.txt:73 (INCLUDE)


Configuring incomplete, errors occurred!

I see that the CMakeModules/ModuleInstall.cmake file has a "FIXME" section for OSX for the install target. Is this causing the problem?
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: CMake configure error on Mac OSX 10.5.6

Hi,

FIXME sounds like a likely culprit :)

Unfortunately we don't have any Macs here. But we will take a look all the same and see if it's something obvious! Thanks for the heads up..

Glenn
Glenn Waldron / Pelican Mapping
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: CMake configure error on Mac OSX 10.5.6

Hi Gerrick!

Can you try replacing that block with this and let us know if it works?  I don't have  a Mac here to test with so I'm just guessing on this.

IF(NOT APPLE)
INSTALL(
    FILES        ${LIB_PUBLIC_HEADERS}
    DESTINATION ${INSTALL_INCDIR}/${LIB_NAME}
)
ENDIF(NOT APPLE)

Thanks!

Jason
G-Bivins G-Bivins
Reply | Threaded
Open this post in threaded view
|

Re: CMake configure error on Mac OSX 10.5.6

Sorry for the late reply. I updated and all is well here!!!
Awesome work guys!!!!
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: CMake configure error on Mac OSX 10.5.6

Hi Gerrick,

Did you just have to do an SVN update to get it to work on OSX or did it require you to make changes to the CMake?

Happy to hear you are up and running:)

Jason

On Mon, Jan 26, 2009 at 9:33 AM, G-Bivins (via Nabble) <[hidden email]> wrote:
Sorry for the late reply. I updated and all is well here!!!
Awesome work guys!!!!



View message @ http://n2.nabble.com/CMake-configure-error-on-Mac-OSX-10.5.6-tp2197959p2218203.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.


G-Bivins G-Bivins
Reply | Threaded
Open this post in threaded view
|

Re: CMake configure error on Mac OSX 10.5.6

Just an update did the trick. I believe the error that Robert was seeing with config was the issue. I'm using makefiles rather than XCode on mac and I find it tends to be on track with the linux builds...ie if linux builds mac w/ makefiles usually builds. CMake is pretty good for handling that. The only conflicts arise when the cmake files create applications but don't accommodate for "bundles"...anyway, All is well here!