Cannot View .ive

classic Classic list List threaded Threaded
3 messages Options
DPD DPD
Reply | Threaded
Open this post in threaded view
|

Cannot View .ive

I am able to view a .ive using osgviewer [filename] command.  

I then created a .earth file with:

<image name="fwbt_1" driver="vpb">
        <url>C:\\vpb\\fwbt.ive</url>
      <primary_split_level>2</primary_split_level> 
        <secondary_split_level>5</secondary_split_level> 
        <profile>global-geodetic</profile> 
    </image>

    <heightfield name="fwbt_2" driver="vpb"> 
       <url>C:\\vpb\\fwbt.ive</url> 
       <primary_split_level>2</primary_split_level> 
       <secondary_split_level>5</secondary_split_level> 
       <profile>global-geodetic</profile> 
    </heightfield> 


Nothing is displayed.  Console output is:  could not get valid heightfield for TileKey 0_1_2_1, etc.

When I comment out the heightfield,  only a white sphere is displayed ( although after building with the -- terrain option my file is now "white" terrain too).

Should I rebuild the terrain?


fwbt.osg.txt
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: Cannot View .ive

Hello,

It looks as if you have created a projected map (not a globe) from looking at your osgconv output, which explains why things aren't working.

Can you take a quick step back and explain what you are trying to accomplish and what data you are working with?  What you are trying to do may be much simpler by just using osgEarth by itself rather than trying to use VPB within osgEarth.

Thanks,

Jason

On Thu, Sep 24, 2009 at 4:32 PM, DPD (via Nabble) <[hidden email]> wrote:
I am able to view a .ive using osgviewer [filename] command.  

I then created a .earth file with:

<image name="fwbt_1" driver="vpb">
        <url>C:\\vpb\\fwbt.ive</url>
      <primary_split_level>2</primary_split_level>
        <secondary_split_level>5</secondary_split_level>
        <profile>global-geodetic</profile>
    </image>

    <heightfield name="fwbt_2" driver="vpb">
       <url>C:\\vpb\\fwbt.ive</url>
       <primary_split_level>2</primary_split_level>
       <secondary_split_level>5</secondary_split_level>
       <profile>global-geodetic</profile>
    </heightfield>


Nothing is displayed.  Console output is:  could not get valid heightfield for TileKey 0_1_2_1, etc.

When I comment out the heightfield,  only a white sphere is displayed ( although after building with the -- terrain option my file is now "white" terrain too).

Should I rebuild the terrain?


fwbt.osg.txt


View message @ http://n2.nabble.com/Cannot-View-ive-tp3708571p3708571.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.


gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: Cannot View .ive

In reply to this post by DPD
Hi [dpd]

You did not show your <map> tag; are you trying to render projected or geocentric?

Your terrain appears to be flat, NAD83, and only a part of the earth. But your .earth file sets a "global-geodetic" profile.. global-geodetic is a built-in profile that represents the entire earth, so it will not work for your terrain.

Read this for information on specifying the right profile:
http://wush.net/trac/osgearth/wiki/MapElementProfile

Glenn
Glenn Waldron / Pelican Mapping