Failed to load a geotiff file using GDAL driver in 2.7 but work in 2.4

classic Classic list List threaded Threaded
4 messages Options
davidip davidip
Reply | Threaded
Open this post in threaded view
|

Failed to load a geotiff file using GDAL driver in 2.7 but work in 2.4

In osgEarth 2.4, I was able to use GDAL driver to load a geotiff (.tif file). But now switch to 2.7 and it failed to load and output this error message (SpatialReference: Failed to initialize a geographic SRS for transverse_mercator). Is there a change in API that I need to do more or modify?

Also unable to load other drivers map, e.g. ArcGIS, tms, wms, vpb, etc. Thanks.
ago ago
Reply | Threaded
Open this post in threaded view
|

Re: Failed to load a geotiff file using GDAL driver in 2.7 but work in 2.4

Hi davidip

  The gdal of osgEarth has always been stable, and I guess your running directory lacks proj's library.

  ArcGIS, TMS, WMS, VPB generally do not have problems, of course, osg basic format plug-ins such as JPG, PNG and TIF need to be compiled.
SXEarth,a free osgEarth GUI Editor and Flight Simulation.

Email: seegogo@126.com
SXEarth download: http://www.sxsim.com/en/

davidip davidip
Reply | Threaded
Open this post in threaded view
|

Re: Failed to load a geotiff file using GDAL driver in 2.7 but work in 2.4

Thanks.
davidip davidip
Reply | Threaded
Open this post in threaded view
|

Re: Failed to load a geotiff file using GDAL driver in 2.7 but work in 2.4

In reply to this post by ago
Hi ago,

Is this URL “http://services.arcgisonline.com/ArcGIS/rest/services/World_Imagery/MapServer” still good for the ARCGIS driver. Worked in 2.4. But in 2.7, I got the following error messages.

[osgEarth]* [TileSource] Open failed: [osgearth] [ArcGIS] map service initialization failed: Unable to read metadata from ArcGIS service
[osgEarth]* [TerrainLayer] “http://services.arcgisonline.com/ArcGIS/rest/services/World_Imagery/MapServer”:  Could not initialize driver
[osgEarth]* [ImageLayer] http://services.arcgisonline.com/ArcGIS/rest/services/World_Imagery/MapServer Error: layer does not have a valid TileSource, cannot create image

Thanks,