HELP:osgversion.exe wrong

classic Classic list List threaded Threaded
2 messages Options
Medwin Medwin
Reply | Threaded
Open this post in threaded view
|

HELP:osgversion.exe wrong

This post was updated on .
When I compile the osgearth using CMake 2.4.7 ,It appears:


OSG_VERSION_EXE ,it can  find osgversion.exe but it's wrong !
"osgversion was found at L:/../osgversion.exe,but failed to run."
why?

My osg version is 2.6.0 !
please help !thanks
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: HELP:osgversion.exe wrong

Hi Medwin,

To us the OSG_VERSION_EXE feature of the osgEarth CMake, all of the osg binaries need to be in your PATH before running CMake.  Simply setting the OSG_VERSION_EXE variable to the path of osgversion will not work since osgversion.exe needs osg.dll in the path to run.

If you don't use the OSG_VERSION_EXE, the only downside is that your plugins will be installed to c:\Program Files\OSGEARTH\lib instead of C:\Program Files\OSGEARTH\lib\osgPlugins-2.6.0

That feature is much more useful on Linux.

Thanks!

Jason

On Fri, Mar 27, 2009 at 8:37 AM, Medwin (via Nabble) <[hidden email]> wrote:
When I compile the osgearth using CMake 2.4.7 ,It appears:


My osg version is 2.6.0 !
please help me !thanks


View message @ http://n2.nabble.com/HELP%3Aosgversion.exe-wrong-tp2544077p2544077.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.