Help with using shared texture GLOBCOVER_L4_200901_200912_V2.3.tif

classic Classic list List threaded Threaded
4 messages Options
DC DC
Reply | Threaded
Open this post in threaded view
|

Help with using shared texture GLOBCOVER_L4_200901_200912_V2.3.tif

I have used the GLOBCOVER_L4_200901_200912_V2.3.tif mask to display ocean sand and 'blue' Earth (from space) in my own shader splatting.

A code pull after the TileSource refactoring fails with 'mayHaveDataInExtent' because the 'intersects' now fails.
Is there something I need to do now to get the GLOBCOVER_L4_200901_200912_V2.3.tif mask to work? I am still using the 'mp' driver. Using 'rex' driver gives me a black screen.

I also did the gdal_translate as suggested in the osgEarth docs, but still no worky.

Here is my setup in the Earth file:

    <image name="splatmask" visible="false" shared="true" driver="gdal" coverage="true">
        <url>../data/terrain/globemask.tif</url>
        <shared_sampler>mask</shared_sampler>
    </image>

GLOBCOVER_L4_200901_200912_V2.3.tif is renamed 'globemask.tif' after the gdal_translate, but it does not work if I use it or the original GLOBCOVER_L4_200901_200912_V2.3.tif texture.

But it will work with the code before the refactoring.

DC
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: Help with using shared texture GLOBCOVER_L4_200901_200912_V2.3.tif

What "TileSource refactoring" are you referring to?

Try putting <profile>global-geodetic</profile> in your image layer. The GLOBCOVER dataset has a weird extent that can confuse osgEarth.
Glenn Waldron / Pelican Mapping
DC DC
Reply | Threaded
Open this post in threaded view
|

Re: Help with using shared texture GLOBCOVER_L4_200901_200912_V2.3.tif

Refactor TileSource (7ad2cfcc) on 3/15/2017. I am assuming that is where this stopped working for me.

I tried the global geodetic profile. That did not work either.
Nikkitta Nikkitta
Reply | Threaded
Open this post in threaded view
|

Re: Help with using shared texture GLOBCOVER_L4_200901_200912_V2.3.tif

Hi, I also have problem with LandCover and splat.
On my previous build (from the 1st June 2017) everything worked perfect.
Few days ago I've built from master latest OSG and osgEarth. Then, according to examples I've added GPU trees and grass with the help of LandCover data GLOBCOVER_L4_200901_200912_V2.3.tiled.tif.

But now, with the same LandCover file, it doesn't work properly.
I launched splat.earth from the test folder (with modified paths to files) and here is what I get:

Screenshot of Hallstatt

Trees are placed randomly and sparsely I would say. Previously it looked more like a forest.
All the setting about density, fill, max_distance are the same.
I need this only to draw trees and grass. But what's wrong with LandCover data?
Best regards,
Nikita Petrov