How can OsGearth2.10.0 be used to implement older versions of DPLineSegmentIntersector?

classic Classic list List threaded Threaded
3 messages Options
Mirro187 Mirro187
Reply | Threaded
Open this post in threaded view
|

How can OsGearth2.10.0 be used to implement older versions of DPLineSegmentIntersector?

The environment I use osg3.6.4+earth2.10.0+vs2015
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: How can OsGearth2.10.0 be used to implement older versions of DPLineSegmentIntersector?

Mirro187,

OSG 3.6 has double-precision support in its LineSegmentIntersector, so I don't think you need the old DPLineSegmentIntersector any more.
Glenn Waldron / Pelican Mapping
Mirro187 Mirro187
Reply | Threaded
Open this post in threaded view
|

Re: How can OsGearth2.10.0 be used to implement older versions of DPLineSegmentIntersector?

I trying using the PrimitiveIntersector to detect  DPLineSegmentIntersector instead. Is that ok?