Linking problem with MS VS9

classic Classic list List threaded Threaded
3 messages Options
mikew mikew
Reply | Threaded
Open this post in threaded view
|

Linking problem with MS VS9

Hi,

Building this project using VC++ 2008 express edition, I always end up with the following error:
.
.
2>..\..\..\src\osgEarth\CacheSeed.cpp(93) : warning C4018: '<' : signed/unsigned mismatch
2>Caching.cpp
2>Generating Code...
2>Compiling manifest to resources...
2>Microsoft (R) Windows (R) Resource Compiler Version 6.1.6723.1
2>Copyright (C) Microsoft Corporation.  All rights reserved.
2>Linking...
2>C:\Expat 2.0.1\Bin\libexpat.dll : fatal error LNK1107: invalid or corrupt file: cannot read at 0x2A8
2>Build log was saved at "file://c:\osge\binb\src\osgEarth\osgEarth.dir\Debug\BuildLog.htm"
2>osgEarth - 1 error(s), 12 warning(s)
========== Rebuild All: 1 succeeded, 1 failed, 0 skipped ==========

Any ideas?

What other information could I supply which would help?
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: Linking problem with MS VS9

Hi Mike

You want to link against the expat .lib file, not the dll. Hopefully that fixes the problem!

Jason

On May 2, 2009, at 1:24 PM, "mikew (via Nabble) - No Reply" <[hidden email]> wrote:

Hi,

Building this project using VC++ 2008 express edition, I always end up with the following error:
.
.
2>..\..\..\src\osgEarth\CacheSeed.cpp(93) : warning C4018: '<' : signed/unsigned mismatch
2>Caching.cpp
2>Generating Code...
2>Compiling manifest to resources...
2>Microsoft (R) Windows (R) Resource Compiler Version 6.1.6723.1
2>Copyright (C) Microsoft Corporation.  All rights reserved.
2>Linking...
2>C:\Expat 2.0.1\Bin\libexpat.dll : fatal error LNK1107: invalid or corrupt file: cannot read at 0x2A8
2>Build log was saved at "file://c:\osge\binb\src\osgEarth\osgEarth.dir\Debug\BuildLog.htm"
2>osgEarth - 1 error(s), 12 warning(s)
========== Rebuild All: 1 succeeded, 1 failed, 0 skipped ==========

Any ideas?

What other information could I supply which would help?


View message @ http://n2.nabble.com/Linking-problem-with-MS-VS9-tp2771637p2771637.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.

mikew mikew
Reply | Threaded
Open this post in threaded view
|

Re: Linking problem with MS VS9

Wow, thanks. That was fast...and accurate!

Right, on to the next hurdle. :)