ModelNode question

classic Classic list List threaded Threaded
5 messages Options
vigos lee vigos lee
Reply | Threaded
Open this post in threaded view
|

ModelNode question

This post was updated on .
Hi,
When I tried to load a model, something went wrong.I loaded the model in the form of ModelNode and ModelLayer.They all have a problem, that is, their points are too big.
But they look fine in osgViewer .
Did I miss something?
Thank you for your help.
vigos
vigos lee vigos lee
Reply | Threaded
Open this post in threaded view
|

Re: ModelNode question

I loaded osgb with geometry in it.Using GL_POINT_SMOOTH.
vigos
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: ModelNode question

In reply to this post by vigos lee
Try disabling the shaders with this in your earth file layer:

 <shader_policy>disable</shader_policy>
Glenn Waldron / Pelican Mapping
vigos lee vigos lee
Reply | Threaded
Open this post in threaded view
|

Re: ModelNode question

Sorry, it doesn't seem to work.
I used modelNode->setShaderPolicy(osgEarth::SHADERPOLICY_DISABLE);
vigos
vigos lee vigos lee
Reply | Threaded
Open this post in threaded view
|

Re: ModelNode question

The problem is solved.
I reduced the pointsize of the original data.
Sorry to trouble you.
vigos