More details in terrain

classic Classic list List threaded Threaded
5 messages Options
Pablo d'Angelo Pablo d'Angelo
Reply | Threaded
Open this post in threaded view
|

More details in terrain

Hi all,

I'm using osgearth to look at orthoimages with 2.5m resolution and DEMs with 5 meter resolution. It seems that osgearth (or osg), does use slightly only low resolution elevation information. Is there a parameter to force osgearth to use higher resolution meshs?

ciao
  Pablo
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: More details in terrain

Hi Pablo,

osgEarth should be able to handle your imagery and elevation.  What specific issues are you seeing?  Also, what does your map file look like?

Thanks,

Jason

On Thu, Oct 8, 2009 at 3:25 PM, Pablo d'Angelo (via Nabble) <[hidden email]> wrote:
Hi all,

I'm using osgearth to look at orthoimages with 2.5m resolution and DEMs with 5 meter resolution. It seems that osgearth (or osg), does use slightly only low resolution elevation information. Is there a parameter to force osgearth to use higher resolution meshs?

ciao
  Pablo


View message @ http://n2.nabble.com/More-details-in-terrain-tp3790292p3790292.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.


Pablo d'Angelo Pablo d'Angelo
Reply | Threaded
Open this post in threaded view
|

Re: More details in terrain

Hi Jason,

osgearth has no problems with handling the imagery. However I'd like it to use finer meshes for the terrain. It seems to use terrain with a lower resolution than imagery (that is probably fine for most cases, as the terrain does not change as fast at the images). This is mostly visible when the textures are disabled in osgviewer (by pressing the "t" key).

Is there any parameter to force osgearth (or osgterrain) to use a finer mesh than it does by default?

Here is my map file:

<map name="Cartosat" type="flat">
  <image name="inset2" driver="gdal">
        <url>149181AO.tif</url>
        <tile_size>256</tile_size>
  </image>
    <heightfield name="P5" driver="gdal">
        <url>149181DP5f.tif</url>
        <tile_size>32</tile_size>
    </heightfield> 
</map>

ciao
  Pablo
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: More details in terrain

Hi Pablo,

Are you saying that you want the terrain mesh and then the imagery to equal resolution (so when you're viewing 1m imagery you are seeing 1m per pixel terrain?)

You could try to change the tile size of the heightfield to match your imagery (change 32 to 256) but I wouldn't recommend that since you will be creating a ton of geometry and likely cause performance problems.

If you zoom in further your higher resolution elevation data should start showing up while the imagery should stay at it's maximum resolution.

Thanks,

Jason


On Thu, Oct 8, 2009 at 3:39 PM, Pablo d'Angelo (via Nabble) <[hidden email]> wrote:
Hi Jason,

osgearth has no problems with handling the imagery. However I'd like it to use finer meshes for the terrain. It seems to use terrain with a lower resolution than imagery (that is probably fine for most cases, as the terrain does not change as fast at the images). This is mostly visible when the textures are disabled in osgviewer (by pressing the "t" key).

Is there any parameter to force osgearth (or osgterrain) to use a finer mesh than it does by default?

Here is my map file:

<map name="Cartosat" type="flat">
  <image name="inset2" driver="gdal">
        <url>149181AO.tif</url>
        <tile_size>256</tile_size>
  </image>
    <heightfield name="P5" driver="gdal">
        <url>149181DP5f.tif</url>
        <tile_size>32</tile_size>
    </heightfield>
</map>

ciao
  Pablo


I suspect that osgearth is working the way it should, however


View message @ http://n2.nabble.com/More-details-in-terrain-tp3790292p3790385.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.


Pablo d'Angelo Pablo d'Angelo
Reply | Threaded
Open this post in threaded view
|

Re: More details in terrain

Hi Jason,

I should have tried changing the height field tile size before posting here. *Bang head against wall* Tilesize 64 or 128 look nicer than 32 with my current dataset.

Thanks,
  Pablo