Problem with FeatureDisplayLayout

classic Classic list List threaded Threaded
7 messages Options
jayasimha jayasimha
Reply | Threaded
Open this post in threaded view
|

Problem with FeatureDisplayLayout

Hi

 in my application while loading building models i gave "FeatureDisplayLayout".the building are drawing within specified max range (2000 meters),if i am changing heading of my camera,whatever buildings are drawn and going out of 'view frustum' are not drawing.

   i mean i want to disable frustum culling to buildings,which is affecting by "FeatureDisplayLayout",So how i can solve this problem ?
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: Problem with FeatureDisplayLayout

Hi Jaya,

Let me understand - you want to draw geometry that is outside of the view frustum?
Glenn Waldron / Pelican Mapping
jayasimha jayasimha
Reply | Threaded
Open this post in threaded view
|

Re: Problem with FeatureDisplayLayout

Hi

 yaa, i want to draw geometry out side of the view frustum
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: Problem with FeatureDisplayLayout

Perhaps you might try disabling frustum culling on your osg::Camera, perhaps by calling setCullingMode. Anyway this is outside the scope of osgEarth and you get more insights on the OSG mailing list. The first thing they will ask you is why :) Good luck!
Glenn Waldron / Pelican Mapping
jayasimha jayasimha
Reply | Threaded
Open this post in threaded view
|

Re: Problem with FeatureDisplayLayout

No,Everything working fine in Scene but only the problem after loading building models with "FeatureDisplayLayout" and "FeatureLevel" (around 2000 meters range) the building are drawing after launching with-in region( < 2000 meters).
      suppose if i am changing camera view, whatever the building are there in that region are displaying one by one,again if i am changing camera view to previous view,whatever the buildings drawn before are drawing again one by one.

    So i want to disable the option of Removing building models whatever outside of Camera View.if am not giving "FeatureDisplayLayout"  and "FeatureLevel",while launching it is taking some Time to load all the buildings from given shape file,in this case if i am changing camera view and again if i am coming to previous view buildings are not removed and not redrawing.

       So i am facing problem with "FeatureDisplayLayout"  and "FeatureLevel".so what i can do ?
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: Problem with FeatureDisplayLayout

OSG decides when to page data out, and you can control the size of the cache it uses to keep things in memory when they are outside the view frustum. You can set the environment variable OSG_MAX_PAGEDLOD to the cache size you want. The default is 300. Try setting it higher and see if that helps.
Glenn Waldron / Pelican Mapping
jayasimha jayasimha
Reply | Threaded
Open this post in threaded view
|

Re: Problem with FeatureDisplayLayout

ok,i will try.

 Thank you

On Mon, May 15, 2017 at 7:01 PM, gwaldron [via osgEarth] <[hidden email]> wrote:
OSG decides when to page data out, and you can control the size of the cache it uses to keep things in memory when they are outside the view frustum. You can set the environment variable OSG_MAX_PAGEDLOD to the cache size you want. The default is 300. Try setting it higher and see if that helps.
Glenn Waldron / Pelican Mapping



If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/Problem-with-FeatureDisplayLayout-tp7590864p7590879.html
To unsubscribe from Problem with FeatureDisplayLayout, click here.
NAML