Problem with cache only

classic Classic list List threaded Threaded
3 messages Options
franz franz
Reply | Threaded
Open this post in threaded view
|

Problem with cache only

I have problem while using local cache data    
since I made an update of osgearth trunk.

I've got now an error message
"[osgEarth::WMS] Unable to read WMS GetCapabilities; failing.
[osgEarth::MapLayer]  Could not initialize TileSource for layer mosaic
Could not get a valid profile for Layer mosai"
and no tiles are loaded.

My Earth file looks like this

<image name="mosaic" driver="wms">
       <cache_only>true</cache_only>
       <cache type="tms">
           <path>cache_tms</path>
       </cache>   
       <url>http://onearth.jpl.nasa.gov/wms.cgi</url>
       <layers>global_mosaic</layers>
       <format>jpeg</format>
       <tile_size>512</tile_size>
    </image> 

Does anyone know how to fix it ?
thanks by advance

franz
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: Problem with cache only

Hi Franz,

You need to specify the cache at the map level only now.  For example:

<map name="map" type="geocentric">
  <image>
    ...
  </image>

   <cache cache_only="true">
     <path>cache_tms</path>
   </cache>
</map>

Thanks,

Jason

On Thu, Oct 8, 2009 at 9:16 AM, franz (via Nabble) - No Reply <[hidden email]> wrote:
I have problem while using local cache data    
since I made an update of osgearth trunk.

I've got now an error message
"[osgEarth::WMS] Unable to read WMS GetCapabilities; failing.
[osgEarth::MapLayer]  Could not initialize TileSource for layer mosaic
Could not get a valid profile for Layer mosai"
and no tiles are loaded.

My Earth file looks like this

<image name="mosaic" driver="wms">
       <cache_only>true</cache_only>
       <cache type="tms">
           <path>cache_tms</path>
       </cache>    
       <url>http://onearth.jpl.nasa.gov/wms.cgi</url>
       <layers>global_mosaic</layers>
       <format>jpeg</format>
       <tile_size>512</tile_size>
    </image>

Does anyone know how to fix it ?
thanks by advance

franz


View message @ http://n2.nabble.com/Problem-with-cache-only-tp3787940p3787940.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.


franz franz
Reply | Threaded
Open this post in threaded view
|

Re: Problem with cache only

Awesome !
Thanks a lot

franz