Remove Model Layer

classic Classic list List threaded Threaded
5 messages Options
clhermit clhermit
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Remove Model Layer

Hi,

I'm using osgearth master and I can't remove a model Layer, this feature was available for osgearth 2.8.

This problem can be reproduce with osgearth_toc and feature_draped_polygons.earth.

The way to get around this behavior is to use the visibility but the layer is still in memory ?

For example if a model contains hundreds of polygons, what is the correct way to remove them?

Thanks,




gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Remove Model Layer

Thanks for the report - we will take a look at this shortly.
Glenn Waldron / Pelican Mapping
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Remove Model Layer

I've entered an issue for this in Github at https://github.com/gwaldron/osgearth/issues/925

On Thu, Jun 22, 2017 at 10:40 AM gwaldron [via osgEarth] <[hidden email]> wrote:
Thanks for the report - we will take a look at this shortly.
Glenn Waldron / Pelican Mapping



If you reply to this email, your message will be added to the discussion below:
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Remove Model Layer

Pushed a fix - 31526f4
Glenn Waldron / Pelican Mapping
clhermit clhermit
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Remove Model Layer

Thank's for your quick fix.
Loading...