Resting frame rate question

classic Classic list List threaded Threaded
5 messages Options
Josiah425 Josiah425
Reply | Threaded
Open this post in threaded view
|

Resting frame rate question

Hello,

I am curious as to why I'm receiving such low frame rate for a map node with no children.

I have 50 FPS when nothing is rendered on the map at all, just creating the mapnode and displaying the viewer.  My earth file has no data in it.  I can not seem to push above 50 FPS.

I am using osgEarth 2.10, and a high end CPU / GPU.  My screen resolution is 2560 x 1600, but even dropping this down to 1920 x 1080 doesn't put me above 60 FPS.

I am on a Linux machine.

I want to know if maybe there's something I can do outside of optimizing my scene graph that could increase my frame rate?  Because 50 FPS for nothing being rendered seems low to me and could mean no matter how much I optimize, I won't get better than what I'm seeing when my map is populated.
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: Resting frame rate question

Please post the output of

osgearth_version --caps

Thanks
Glenn Waldron / Pelican Mapping
Josiah425 Josiah425
Reply | Threaded
Open this post in threaded view
|

Re: Resting frame rate question

osgEarth Library 2.10.0

[osgEarth]  [Capabilities] osgEarth Version: 2.10.0
[osgEarth]  [Capabilities] Detected hardware capabilities:
[osgEarth]  [Capabilities]   Vendor = NVIDIA Corporation
[osgEarth]  [Capabilities]   Renderer = GeForce GTX 1060 6GB/PCIe/SSE2
[osgEarth]  [Capabilities]   Version = 4.6.0 NVIDIA 430.50
[osgEarth]  [Capabilities]   Core Profile = no
[osgEarth]  [Capabilities]   Max GPU texture units = 32
[osgEarth]  [Capabilities]   Max GPU texture coord indices = 8
[osgEarth]  [Capabilities]   Max GPU attributes = 16
[osgEarth]  [Capabilities]   Depth buffer bits = 24
[osgEarth]  [Capabilities]   Max texture size = 32768
[osgEarth]  [Capabilities]   GLSL = yes
[osgEarth]  [Capabilities]   GLSL Version = 460
[osgEarth]  [Capabilities]   Texture arrays = yes
[osgEarth]  [Capabilities]   draw instanced = yes
[osgEarth]  [Capabilities]   Texture buffers = yes
[osgEarth]  [Capabilities]   Texture buffer max size = 134217728
[osgEarth]  [Capabilities]   Compression = ARB S3 RG
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: Resting frame rate question

Looks good, not sure what the issue is.
Note that your FPS won't go above 60hz unless you disable VSYNC.
Glenn Waldron / Pelican Mapping
nmielcarek nmielcarek
Reply | Threaded
Open this post in threaded view
|

Re: Resting frame rate question

In reply to this post by Josiah425
Are you using the debug versions of OSG and osgEarth? Try recompiling them for Release instead, I've found that's a common case for low frame rates.