Run osgEarth 2.8 with OpenGL ES 2

classic Classic list List threaded Threaded
2 messages Options
Valtiel Valtiel
Reply | Threaded
Open this post in threaded view
|

Run osgEarth 2.8 with OpenGL ES 2

Hi,

I'm trying to run osgEarth on an iPad which only implement OpenGL ES 2.

But after investigate some classes like "ShaderFactory", it just looks quite impossible. Everything seems to be implemented for OpenGL ES 3. Interface Blocks are used, "in/out" instead of "attribute" everywhere and so on.

Does someone have migrate/fork the shaders code for OpenGL ES 2 ? Or do I miss something simple ?

Thank you.
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: Run osgEarth 2.8 with OpenGL ES 2

Viltiel,

osgEarth 2.8 doesn't support GLES. Version 2.7 supported it to some extent but I don't recall the details of the iOS support exactly.
Glenn Waldron / Pelican Mapping