Set LODBlending without .earth file

classic Classic list List threaded Threaded
2 messages Options
Sonny Sonny
Reply | Threaded
Open this post in threaded view
|

Set LODBlending without .earth file

I'm trying to load a map, and use the LODBlending for the smooth transitions.

Whenever I load a map using an earth file with the <LODBlending/> tag inside, the program works just fine and the transitions appear.

However, using the API,something like this:
    osgEarth::Util::LODBlending* myLODEffect = new osgEarth::Util::LODBlending();"

gives me a Linker (?) error like this:
    LNK2019: unresolved external symbol "__declspec(dllimport) public: __cdecl osgEarth::Util::LODBlending::LODBlending(void)"...

I know that this would look like a simple misplaced .lib or .dll, but the issue doesn't show up when using the earth file, and I'm using other functions that require use of osgEarthUtilsd.dll, such as setting up the EarthManipulator.

So I was hoping someone could shed some light on what I'm missing or doing wrong.

Thanks.
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: Set LODBlending without .earth file

Sonny,
Looks like a bug. You should be able to work around it by using a blank options structure like so:

myLODEffect = new osgEarth::Util::LODBlending(osgEarth::Util::LODBlendingOptions());

Hope this helps.
Glenn Waldron / Pelican Mapping