TMS read from gdal2tile respository

classic Classic list List threaded Threaded
5 messages Options
andrews andrews
Reply | Threaded
Open this post in threaded view
|

TMS read from gdal2tile respository

Hi

i created tms repository using gdal2tile. i tried to read the repository with

<map version="2" type="geocentric">
        <image name="base" driver="gdal">
                <url>C:/Users/world.tif>
        </image>
        <image name="layer1" driver="tms">
                <url>C:/Users/Repository/pan.xml</url>
        </image>
</map>

it is not loading tms layer. instead, i get message as
[TMSTileSource] Cannot create writer;writing disable

i know well that tms writing is no longer supported. but i am trying to read only.
but why i get this message?
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: TMS read from gdal2tile respository

Can you post the pan.xml file so I can take a look at it?

Jason

On Wed, Feb 28, 2018 at 11:26 AM andrews [via osgEarth] <[hidden email]> wrote:
Hi

i created tms repository using gdal2tile. i tried to read the repository with

<map version="2" type="geocentric">
        <image name="base" driver="gdal">
                <url>C:/Users/world.tif>
        </image>
        <image name="layer1" driver="tms">
                <url>C:/Users/Repository/pan.xml</url>
        </image>
</map>

it is not loading tms layer. instead, i get message as
[TMSTileSource] Cannot create writer;writing disable

i know well that tms writing is no longer supported. but i am trying to read only.
but why i get this message?



If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/TMS-read-from-gdal2tile-respository-tp7591696.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: TMS read from gdal2tile respository

In reply to this post by andrews
Hi Andrew,

I just tested with a TMS repo generated from gdal2tiles.  I don't get the same warning you do about failing to create a writer, but there was an issue with the data extents being in the incorrect SRS.  gdal2tiles always dumps out the BoundingBox as lat/lon even when the output profile is mercator, and we assume that the BoundingBox should be in the same SRS as the tiles (it should be, and usually is).

If you post your xml file I'll take a look, but I think it should work fine now.

Jason

On Tue, Mar 6, 2018 at 12:03 PM Jason Beverage <[hidden email]> wrote:
Can you post the pan.xml file so I can take a look at it?

Jason

On Wed, Feb 28, 2018 at 11:26 AM andrews [via osgEarth] <[hidden email]> wrote:
Hi

i created tms repository using gdal2tile. i tried to read the repository with

<map version="2" type="geocentric">
        <image name="base" driver="gdal">
                <url>C:/Users/world.tif>
        </image>
        <image name="layer1" driver="tms">
                <url>C:/Users/Repository/pan.xml</url>
        </image>
</map>

it is not loading tms layer. instead, i get message as
[TMSTileSource] Cannot create writer;writing disable

i know well that tms writing is no longer supported. but i am trying to read only.
but why i get this message?



If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/TMS-read-from-gdal2tile-respository-tp7591696.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML
andrews andrews
Reply | Threaded
Open this post in threaded view
|

Re: TMS read from gdal2tile respository

My pan.xml is

<?xml version="1.0" encoding="UTF-8"?>
<TileMap tilemapservice="http://tms.osgeo.org/1.0.0" version="1.0.0">
        <Title>country.vrt</Title>
        <Abstract/>
        <SRS>EPSG:900913</SRS>
        <BoundingBox maxy="92.50" maxx="28.50" miny="88.5" minx="26.4999"/>
        <Origin y="88.5" x="26.5""/>
        <TileFormat extension="png" mime-type="image/png" height="256" width="256"/>
        <TileSets profile="mercator">
                <TileSet order="5" units-per-pixel="4891.9698" href="5"/>
                <TileSet order="6" units-per-pixel="2445.9849" href="6"/> 
                <TileSet order="7" units-per-pixel="1222.99245" href="7"/>
                <TileSet order="8" units-per-pixel="611.496225" href="8"/>
                <TileSet order="9" units-per-pixel="305.7481125" href="9"/>
                <TileSet order="10" units-per-pixel="152.87405625" href="10"/> 
                <TileSet order="11" units-per-pixel="76.437028125" href="11"/>
                <TileSet order="12" units-per-pixel="38.2185140625" href="12"/>
                <TileSet order="13" units-per-pixel="19.10925703125" href="13"/>
                <TileSet order="14" units-per-pixel="9.554628515625" href="14"/> 
                <TileSet order="15" units-per-pixel="4.7773142578125" href="15"/>
        </TileSets>
</TileMap>
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: TMS read from gdal2tile respository

Can you give it a shot with the master osgEarth?  I don't see any issues here.

If you continue to have issues can you zip up your tms repo and stick it somewhere so I can try to reproduce it?

Thanks!

Jason

On Wed, Mar 7, 2018 at 2:31 AM andrews [via osgEarth] <[hidden email]> wrote:
My pan.xml is

<?xml version="1.0" encoding="UTF-8"?>
<TileMap tilemapservice="http://tms.osgeo.org/1.0.0" version="1.0.0">
        <Title>country.vrt</Title>
        <Abstract/>
        <SRS>EPSG:900913</SRS>
        <BoundingBox maxy="92.50" maxx="28.50" miny="88.5" minx="26.4999"/>
        <Origin y="88.5" x="26.5""/>
        <TileFormat extension="png" mime-type="image/png" height="256" width="256"/>
        <TileSets profile="mercator">
                <TileSet order="5" units-per-pixel="4891.9698" href="5"/>
                <TileSet order="6" units-per-pixel="2445.9849" href="6"/> 
                <TileSet order="7" units-per-pixel="1222.99245" href="7"/>
                <TileSet order="8" units-per-pixel="611.496225" href="8"/>
                <TileSet order="9" units-per-pixel="<a href="tel:(305)%20748-1125" value="+13057481125" target="_blank">305.7481125" href="9"/>
                <TileSet order="10" units-per-pixel="152.87405625" href="10"/> 
                <TileSet order="11" units-per-pixel="76.437028125" href="11"/>
                <TileSet order="12" units-per-pixel="38.<a href="tel:(218)%20514-0625" value="+12185140625" target="_blank">2185140625" href="12"/>
                <TileSet order="13" units-per-pixel="19.10925703125" href="13"/>
                <TileSet order="14" units-per-pixel="9.554628515625" href="14"/> 
                <TileSet order="15" units-per-pixel="4.7773142578125" href="15"/>
        </TileSets>
</TileMap>


If you reply to this email, your message will be added to the discussion below:
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML