Tiles appear to have beveling on edges

classic Classic list List threaded Threaded
7 messages Options
Adam Adam
Reply | Threaded
Open this post in threaded view
|

Tiles appear to have beveling on edges

Hi again guys,

Just pulled from current and changed :
curl_easy_setopt(_curl_handle, CURLOPT_NOPROGRESS,FALSE);
to
curl_easy_setopt(_curl_handle, CURLOPT_NOPROGRESS,(void*)0);
so it would compile.

I'm now seeing what looks like beveling on the edges of the tiles.  Using gdal driver, with dted0 data:
<map name="dted geotiff example" type="geocentric">
   <heightfield name="terrain" driver="gdal">
      <url>/home/adam/dted0</url>
      <extensions>dt0</extensions>
      <tile_size>32</tile_size>
      <max_level>5</max_level>
   </heightfield>
</map>

Is this a known problem?  Granted it looks kind of cool while I'm testing, but big shadowy lines won't fly later.

Still waiting for approval to send screenshots and such, sorry.
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: Tiles appear to have beveling on edges

Try again now. Temporary snafu :)

Glenn
Glenn Waldron / Pelican Mapping
Adam Adam
Reply | Threaded
Open this post in threaded view
|

Re: Tiles appear to have beveling on edges

Looks good, but that won't fix the beveled edges on tiles :)
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: Tiles appear to have beveling on edges

Do you see the problem with any of the samples? like srtm.earth?

Glenn
Glenn Waldron / Pelican Mapping
Adam Adam
Reply | Threaded
Open this post in threaded view
|

Re: Tiles appear to have beveling on edges

Ah, good call.  I see it with: gdal_multiple_files.earth

I know I didn't see it with r566, and I don't think I saw it with r674 or r679.
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: Tiles appear to have beveling on edges

Hi Adam,

Try updating now and see if that fixes your issue, we were missing some commits.

Thanks!

Jason

On Thu, Oct 15, 2009 at 11:51 AM, Adam (via Nabble) - No Reply <[hidden email]> wrote:
Ah, good call.  I see it with: gdal_multiple_files.earth

I know I didn't see it with r566, and I don't think I saw it with r674 or r679.


View message @ http://n2.nabble.com/Tiles-appear-to-have-beveling-on-edges-tp3829793p3830173.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.


Adam Adam
Reply | Threaded
Open this post in threaded view
|

Re: Tiles appear to have beveling on edges

Yep that fixed it!  Thanks again for the quick responses!

Adam