TrackNodes flattened

classic Classic list List threaded Threaded
5 messages Options
Thomas Stegemann Thomas Stegemann
Reply | Threaded
Open this post in threaded view
|

TrackNodes flattened

This post was updated on .
After upgrading from osgEarth 2.7 to latest 2.9 my tracknodes are flattened down to earth (drawn upon earth tile) instead of being aligned to camera view. Also the symbol is very small in size and scales with the view instead of having the same size independent from view distance.

But the compiled tracknode sample works.

Any ideas what could be the reason? Worked well with 2.7 but no longer.
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: TrackNodes flattened

Where are they in your scene graph? Are they under a DrapeableNode or ClampableNode? Are they under the MapNode somewhere?
Glenn Waldron / Pelican Mapping
Thomas Stegemann Thomas Stegemann
Reply | Threaded
Open this post in threaded view
|

Re: TrackNodes flattened

The TrackNode is a child of a GroupNode that is under the RootNode.

The code is somewhat cluttered into several methods, so it is hard to post here.

gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: TrackNodes flattened

Try putting your track node group under the MapNode.
Glenn Waldron / Pelican Mapping
Thomas Stegemann Thomas Stegemann
Reply | Threaded
Open this post in threaded view
|

Re: TrackNodes flattened

Ok, I'll try. Sure about that? From tracknode example (which works):

    osg::Group* tracks = new osg::Group();
    createTrackNodes( mapNode, tracks, schema, trackSims );
    root->addChild( tracks );