Transparency of elevation without image

classic Classic list List threaded Threaded
4 messages Options
Christian Schulte Christian Schulte
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Transparency of elevation without image

Hello,

I'm trying to make a database with some local data MNT (geotiff) and OrthoPhotos (geotiff) of a region of France. As the MNT coverage is larger than the Orthophoto coverage I wanted to set the color of the terrain to transparent as explained in the FAQ (terrain color set to #ffffff00). The problem is that the elevation data is still white. I've tried playing with the blending, feather_pixel but have found no solution.
Here is my .earth file :

<map name="04" type="projected" version="2">
        <options
                lighting = "true"
                elevation_interpolation = "bilinear"
                elevation_tile_size = "17"
                overlay_texture_size = "4096"
                overlay_blending = "true"
                overlay_resolution_ratio = "3.0" >   
                <terrain
                        driver = "mp"
                        lighting = "true"
                        min_tile_range_factor = "6"
                        min_lod = "0"
                        max_lod = "23"
                        first_lod = "0"
                        cluster_culling = "true"
                        mercator_fast_path = "true"
                        blending = "true"
                        color = "#ffffff00"
                        tile_size = "17"
                        normalize_edges = "false"
                        elevation_smoothing = "false"/>
        </options>
  <image name="OrthoLayer" driver="gdal" feather_pixels="true" enabled="true">
    <url>Z:/newTest/CorrectedORTHO/04/reprojected</url>
  </image>
  <elevation name="ElevationLayer" driver="gdal" enabled="true">
    <url>Z:/newTest/CorrectedMNT/04/newTest</url>
  </elevation>
</map>

Do you have any idea ?

Thanks,

Christian
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Transparency of elevation without image

Christian,

Which version of osgEarth? I just tested this in the master branch and it worked as expected. (I used the readymap elevation layer from readymap_flat.earth along with an inset layer from hires_insets.earth, and a terrain color of #ffff00.
Glenn Waldron / Pelican Mapping
Christian Schulte Christian Schulte
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Transparency of elevation without image

Hi Glenn,

I'm using osgEarth 2.7.0 on Windows 7. I've tested too with readymap and hires and got the expected result. After digging somemore in my data I found that the problem is on my data. I have split an unique orthoimage in multiple geotiff. The problem is tha this unique orthoimage had a white background color so it generated the white tiles where I thought there was no image layer. I will have to find a proper manner to set a transparency mask to this useless data in order to succeed.
Thanks and sorry to have bothered you with a wrong problem.

Regards,

Christian
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Transparency of elevation without image

No worries! I have been tricked by that very thing myself in the past - an image with white background areas :)

Glad you figured it out.
Glenn Waldron / Pelican Mapping
Loading...