Triton not working well when using local tms driver

classic Classic list List threaded Threaded
3 messages Options
Wallee Wallee
Reply | Threaded
Open this post in threaded view
|

Triton not working well when using local tms driver

Hi Experts,

It was working well when using the default sample in bin directory:
..OsgAndOsgEarth\OsgEarth2.8_SDK\bin>osgearth_viewer.exe ..\OsgEarth2.8_SDK\tests\triton.earth
working good

However, when I changed the tms from remote to local, the triton water surface stopped moving, and looks even triton was not rendered correctly, would you help me with this issue? Thanks.

tms changed:
FROM:
<elevation name="readymap_elevation" driver="tms">
    <url>http://readymap.org/readymap/tiles/1.0.0/9/</url>
</elevation>-->
TO:
<image name="readymap_imagery" driver="tms" visible="true">
    <url>C:/Users/Administrator/Desktop/OsgAndOsgEarth/OsgEarth2.8_SDK/bin/tms/tms.xml</url>
</image>
gis gis
Reply | Threaded
Open this post in threaded view
|

Re: Triton not working well when using local tms driver

try setting up tritonOptions.useHeightMap() = false on your c++ code, or you can config earth xml file like this:
<ocean driver="triton">
      <use_height_map>false</use_height_map>
      <resource_path>D:/Triton SDK/Resources</resource_path>
      <height_map_size>5000</height_map_size>
</ocean>
Wallee Wallee
Reply | Threaded
Open this post in threaded view
|

Re: Triton not working well when using local tms driver

Hi Gis,
Thanks for your help, it really works. : )