What version of OpenSceneGraph I should build OsgEarth with?

classic Classic list List threaded Threaded
2 messages Options
dmitriano dmitriano
Reply | Threaded
Open this post in threaded view
|

What version of OpenSceneGraph I should build OsgEarth with?

I tried to build different combinations of OpenSceneGraph and OsgEarth versions and got cmake errors or compiler errors, for example building osgearth-2.8 with OpenSceneGraph-3.5.6 results in compiler errors. But if I get the latest versions of both OpenSceneGraph and OsgEarth they build fine. So, what version of OpenSceneGraph I should build OsgEarth with? Detailed description of my build steps: https://developernote.com/2017/08/building-osgearth-on-ubuntu-14-04/
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: What version of OpenSceneGraph I should build OsgEarth with?

Dmitri,
You should build osgEarth 2.8 against OSG 3.4. You can build the master branch against OSG 3.4 or newer.
Glenn Waldron / Pelican Mapping