White Globe on OSGEarth 2.9

classic Classic list List threaded Threaded
10 messages Options
Mike Metcalf Mike Metcalf
Reply | Threaded
Open this post in threaded view
|

White Globe on OSGEarth 2.9

I reported this yesterday at the bottom of a long post in another thread. For future reference, to make things easier to find, I thought I would add it as its own thread with a descriptive title.

With OSGEarth 2.9 (using both OSG 3.4.1 and OSG 3.6), we get a white globe when running osgearth_viewer on the arcgisonline.earth file. The white globe does not appear when running the readymap.earth file.

Seems like there might be an issue in the osgEarth::Drivers::ArcGISOptions or in osgEarth::ImageLayer related to the new 2.9 code...

In the thread "osgearth-2.9 and TMS problem" by Nazarov David, I posted the output from our app (also has the white globe issue) using OSGEARTH_NOTIFY_LEVEL=INFO.

Many thanks in advance for any insight you may be able to offer.

-mike
plevy plevy
Reply | Threaded
Open this post in threaded view
|

Re: White Globe on OSGEarth 2.9

Mike,
arcgisonline.earth is working fine for me with osg master and osgearth master.  Have you tried running without caches? In your other message, it looks like you are using cached imagery.

--
Paul Levy : Pelican Mapping


On Thu, May 3, 2018 at 11:19 AM Mike Metcalf [via osgEarth] <[hidden email]> wrote:
I reported this yesterday at the bottom of a long post in another thread. For future reference, to make things easier to find, I thought I would add it as its own thread with a descriptive title.

With OSGEarth 2.9 (using both OSG 3.4.1 and OSG 3.6), we get a white globe when running osgearth_viewer on the arcgisonline.earth file. The white globe does not appear when running the readymap.earth file.

Seems like there might be an issue in the osgEarth::Drivers::ArcGISOptions or in osgEarth::ImageLayer related to the new 2.9 code...

In the thread "osgearth-2.9 and TMS problem" by Nazarov David, I posted the output from our app (also has the white globe issue) using OSGEARTH_NOTIFY_LEVEL=INFO.

Many thanks in advance for any insight you may be able to offer.

-mike


If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/White-Globe-on-OSGEarth-2-9-tp7591829.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML
Mike Metcalf Mike Metcalf
Reply | Threaded
Open this post in threaded view
|

Re: White Globe on OSGEarth 2.9

Paul,

Thanks a lot for the reply and the additional data points.

The OSGEarth output in the other thread was from our application. (I'm not certain, but I don't think the osgearth_viewer running the arcgisonline.earth uses a cache when invoked at the command line.)

I deleted the cache our app was using, enabled the arcgisonline driver, and restarted the app. Still have the white globe. The osgcache folder has been recreated and is being populated with .meta and .osgb files.

After deleting the cache and re-enabling the arcgisonline driver, I get the following output from OSGEARTH_NOTIFY_LEVEL=INFO

_targetMaximumNumberOfPageLOD = 1000
[osgEarth]  [Map] cache=none; policy=read-write; bin=no
[osgEarth]  [engine_mp driver] Activated!
[osgEarth]  [Capabilities] osgEarth Version: 2.9.0
[osgEarth]  [Capabilities] Detected hardware capabilities:
[osgEarth]  [Capabilities]   Vendor = NVIDIA Corporation
[osgEarth]  [Capabilities]   Renderer = Quadro FX 570/PCIe/SSE2
[osgEarth]  [Capabilities]   Version = 3.3.0
[osgEarth]  [Capabilities]   Max GPU texture units = 32
[osgEarth]  [Capabilities]   Max GPU texture coord indices = 8
[osgEarth]  [Capabilities]   Max GPU attributes = 16
[osgEarth]  [Capabilities]   Depth buffer bits = 24
[osgEarth]  [Capabilities]   Max texture size = 8192
[osgEarth]  [Capabilities]   Max lights = 8
[osgEarth]  [Capabilities]   GLSL = yes
[osgEarth]  [Capabilities]   GLSL Version = 330
[osgEarth]  [Capabilities]   Texture arrays = yes
[osgEarth]  [Capabilities]   3D textures = yes
[osgEarth]  [Capabilities]   Multitexturing = yes
[osgEarth]  [Capabilities]   draw instanced = yes
[osgEarth]  [Capabilities]   uniform buffer objects = yes
[osgEarth]  [Capabilities]   NPOT textures = yes
[osgEarth]  [Capabilities]   Texture buffers = yes
[osgEarth]  [Capabilities]   Texture buffer max size = 134217728
[osgEarth]  [Capabilities]   Transform feedback = no
[osgEarth]  [Capabilities]   Compression = ARB S3 RG
[osgEarth]  [Map] Map profile is: [srs=WGS 84, min=-180,-90 max=180,90 lod0=2,1 vdatum=geodetic]
[osgEarth]  [TerrainResources] Texture unit 0 reserved for MP Engine Primary
[osgEarth]  [TerrainResources] Texture unit 1 reserved for MP Engine Secondary
[osgEarth]  [MPTerrainEngineNode] Edge normalization is ON
[osgEarth]  [MapNode] Adding ellipsoid uniforms.
[osgEarth]  [FileSystemCache] Opened a filesystem cache at "C:\Users\Public\smotar\osgcache"
8 concurrent threads are supported
StatsHandler::StatsHandler() Setting up GL2 compatible shaders
[osgEarth]  [SimpleSkyNode] Using O'Neil atmospheric lighting
[osgEarth]  [SimpleSkyNode] Couldn't load moon texture, add osgEarth's data directory your OSG_FILE_PATH
[osgEarth]  [TerrainLayer] Layer "ArcGIS Aerial Imagery*" Creating "arcgis" driver
[osgEarth]  [TerrainLayer] Layer "ArcGIS Aerial Imagery*" Cache bin is [cf9bb627]
[osgEarth]  [TerrainLayer] Layer "ArcGIS Aerial Imagery*" Profile=[srs=Mercator CS, min=-20037508.34278925,-20037508.34278925 max=20037508.34278925,20037508.34278925 lod0=1,1 vdatum=geodetic]
[osgEarth]  [TerrainLayer] Layer "ArcGIS Aerial Imagery*" cache=FileSystemCache; policy=read-write; bin=yes
[osgEarth]  [TerrainLayer] Layer "ReadyMap Elevation*" Creating "tms" driver
[osgEarth]  [TerrainLayer] Layer "ReadyMap Elevation*" Cache bin is [2c6ac10a]
[osgEarth]  [TMSTileSource] TMS tile map datestamp = Thu, 01 Jan 1970 00:00:00 GMT
[osgEarth]  [TerrainLayer] Layer "ReadyMap Elevation*" Profile=[srs=WGS 84, min=-180,-90 max=180,90 lod0=2,1 vdatum=geodetic]
[osgEarth]  [TerrainLayer] Layer "ReadyMap Elevation*" cache=FileSystemCache; policy=read-write; bin=yes
[osgEarth]  [ScreenSpaceLayout] Decluttering VP installed
[osgEarth]  [TerrainResources] Texture unit 2 reserved for Draping
[osgEarth]  [DrapingTechnique] Reserved texture image unit 2
[osgEarth]  [DrapingTechnique] Using texture size = 2048
The program has unexpectedly finished.
The process was ended forcefully.



Do I need to run again without enabling caching? While I wait for your reply, I will try that...
plevy plevy
Reply | Threaded
Open this post in threaded view
|

Re: White Globe on OSGEarth 2.9

Mike,

Can you send the version of osg and osgearth so I can try to reproduce the white globe with osgearth_viewer?

Or try more recent osg or the master.


--
Paul Levy : Pelican Mapping


On Thu, May 3, 2018 at 12:31 PM Mike Metcalf [via osgEarth] <[hidden email]> wrote:
Paul,

Thanks a lot for the reply and the additional data points.

The OSGEarth output in the other thread was from our application. (I'm not certain, but I don't think the osgearth_viewer running the arcgisonline.earth uses a cache when invoked at the command line.)

I deleted the cache our app was using, enabled the arcgisonline driver, and restarted the app. Still have the white globe. The osgcache folder has been recreated and is being populated with .meta and .osgb files.

After deleting the cache and re-enabling the arcgisonline driver, I get the following output from OSGEARTH_NOTIFY_LEVEL=INFO

_targetMaximumNumberOfPageLOD = 1000
[osgEarth]  [Map] cache=none; policy=read-write; bin=no
[osgEarth]  [engine_mp driver] Activated!
[osgEarth]  [Capabilities] osgEarth Version: 2.9.0
[osgEarth]  [Capabilities] Detected hardware capabilities:
[osgEarth]  [Capabilities]   Vendor = NVIDIA Corporation
[osgEarth]  [Capabilities]   Renderer = Quadro FX 570/PCIe/SSE2
[osgEarth]  [Capabilities]   Version = 3.3.0
[osgEarth]  [Capabilities]   Max GPU texture units = 32
[osgEarth]  [Capabilities]   Max GPU texture coord indices = 8
[osgEarth]  [Capabilities]   Max GPU attributes = 16
[osgEarth]  [Capabilities]   Depth buffer bits = 24
[osgEarth]  [Capabilities]   Max texture size = 8192
[osgEarth]  [Capabilities]   Max lights = 8
[osgEarth]  [Capabilities]   GLSL = yes
[osgEarth]  [Capabilities]   GLSL Version = 330
[osgEarth]  [Capabilities]   Texture arrays = yes
[osgEarth]  [Capabilities]   3D textures = yes
[osgEarth]  [Capabilities]   Multitexturing = yes
[osgEarth]  [Capabilities]   draw instanced = yes
[osgEarth]  [Capabilities]   uniform buffer objects = yes
[osgEarth]  [Capabilities]   NPOT textures = yes
[osgEarth]  [Capabilities]   Texture buffers = yes
[osgEarth]  [Capabilities]   Texture buffer max size = 134217728
[osgEarth]  [Capabilities]   Transform feedback = no
[osgEarth]  [Capabilities]   Compression = ARB S3 RG
[osgEarth]  [Map] Map profile is: [srs=WGS 84, min=-180,-90 max=180,90 lod0=2,1 vdatum=geodetic]
[osgEarth]  [TerrainResources] Texture unit 0 reserved for MP Engine Primary
[osgEarth]  [TerrainResources] Texture unit 1 reserved for MP Engine Secondary
[osgEarth]  [MPTerrainEngineNode] Edge normalization is ON
[osgEarth]  [MapNode] Adding ellipsoid uniforms.
[osgEarth]  [FileSystemCache] Opened a filesystem cache at "C:\Users\Public\smotar\osgcache"
8 concurrent threads are supported
StatsHandler::StatsHandler() Setting up GL2 compatible shaders
[osgEarth]  [SimpleSkyNode] Using O'Neil atmospheric lighting
[osgEarth]  [SimpleSkyNode] Couldn't load moon texture, add osgEarth's data directory your OSG_FILE_PATH
[osgEarth]  [TerrainLayer] Layer "ArcGIS Aerial Imagery*" Creating "arcgis" driver
[osgEarth]  [TerrainLayer] Layer "ArcGIS Aerial Imagery*" Cache bin is [cf9bb627]
[osgEarth]  [TerrainLayer] Layer "ArcGIS Aerial Imagery*" Profile=[srs=Mercator CS, min=-20037508.34278925,-20037508.34278925 max=20037508.34278925,20037508.34278925 lod0=1,1 vdatum=geodetic]
[osgEarth]  [TerrainLayer] Layer "ArcGIS Aerial Imagery*" cache=FileSystemCache; policy=read-write; bin=yes
[osgEarth]  [TerrainLayer] Layer "ReadyMap Elevation*" Creating "tms" driver
[osgEarth]  [TerrainLayer] Layer "ReadyMap Elevation*" Cache bin is [2c6ac10a]
[osgEarth]  [TMSTileSource] TMS tile map datestamp = Thu, 01 Jan 1970 00:00:00 GMT
[osgEarth]  [TerrainLayer] Layer "ReadyMap Elevation*" Profile=[srs=WGS 84, min=-180,-90 max=180,90 lod0=2,1 vdatum=geodetic]
[osgEarth]  [TerrainLayer] Layer "ReadyMap Elevation*" cache=FileSystemCache; policy=read-write; bin=yes
[osgEarth]  [ScreenSpaceLayout] Decluttering VP installed
[osgEarth]  [TerrainResources] Texture unit 2 reserved for Draping
[osgEarth]  [DrapingTechnique] Reserved texture image unit 2
[osgEarth]  [DrapingTechnique] Using texture size = 2048
The program has unexpectedly finished.
The process was ended forcefully.



Do I need to run again without enabling caching? While I wait for your reply, I will try that...



If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/White-Globe-on-OSGEarth-2-9-tp7591829p7591831.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML
Mike Metcalf Mike Metcalf
Reply | Threaded
Open this post in threaded view
|

Re: White Globe on OSGEarth 2.9

Paul,

We are using:

OSG 3.4.1  (see note below*)
OSGEarth 2.9.0

also:
Qt: 5.10.1
Boost 1.66.0

*We also have another dev machine on which was built OSGEarth 2.9 linked against OSG 3.6.0 which exhibits the same white globe in our app, osgearth_viewer.exe and osgearth_qt_simple.exe when using the arcgisonline.earth file. All of these work well with the readymap.earth file.

Just a quick note to also point out something that might be related...

When either our app or osgearth_viewer run with readymap, the shutdown is clean. When either of them run using the arcgisonline driver, there is a crash on exit. FYI... I'm not sure of the significance. I haven't yet built OSGEarth 2.9 or OSG 3.6 in debug to see where the crash might be happening.
Mike Metcalf Mike Metcalf
Reply | Threaded
Open this post in threaded view
|

Re: White Globe on OSGEarth 2.9

Paul,

At a command prompt, I set OSGEARTH_NOTIFY_LEVEL to INFO and invoked osgearth_viewer with the readymap.earth file, then with the arcgisonline file. I have copied and pasted the output here:


C:\3rd_libs\OSG\OSG34_EARTH29_msvc2015\bin>osgearth_viewer ..\tests\readymap.earth
_targetMaximumNumberOfPageLOD = 1000
[osgEarth]  Loading href from C:/3rd_libs/OSG/OSG34_EARTH29_msvc2015/tests/viewpoints.xml
[osgEarth]  [EarthSerializer2] Loaded extension lib "osgPlugins-3.4.1/osgdb_osgearth_viewpoints.dll"
[osgEarth]  [Map] cache=none; policy=read-write; bin=no
[osgEarth]  [TerrainLayer] Layer "readymap_elevation" Creating "tms" driver
[osgEarth]  [TMSTileSource] TMS tile map datestamp = Thu, 01 Jan 1970 00:00:00 GMT
[osgEarth]  override vdatum = egm96, profile vdatum =
[osgEarth]  [VerticalDatum] Initializing vertical datum: egm96
[osgEarth]  [TerrainLayer] Layer "readymap_elevation" Override profile: [srs=WGS 84, min=-180,-90 max=180,90 lod0=2,1 vdatum=EGM96]
[osgEarth]  [TerrainLayer] Layer "readymap_elevation" Profile=[srs=WGS 84, min=-180,-90 max=180,90 lod0=2,1 vdatum=EGM96]
[osgEarth]  [TerrainLayer] Layer "readymap_elevation" cache=none; policy=read-write; bin=no
[osgEarth]  [TerrainLayer] Layer "readymap_imagery" Creating "tms" driver
[osgEarth]  [TMSTileSource] TMS tile map datestamp = Thu, 01 Jan 1970 00:00:00 GMT
[osgEarth]  [TerrainLayer] Layer "readymap_imagery" Profile=[srs=WGS 84, min=-180,-90 max=180,90 lod0=2,1 vdatum=geodetic]
[osgEarth]  [TerrainLayer] Layer "readymap_imagery" cache=none; policy=read-write; bin=no
[osgEarth]  [ViewpointsExtension] Read 8 viewpoints
[osgEarth]  [engine_mp driver] Activated!
[osgEarth]  [Capabilities] osgEarth Version: 2.9.0
[osgEarth]  [Capabilities] Detected hardware capabilities:
[osgEarth]  [Capabilities]   Vendor = NVIDIA Corporation
[osgEarth]  [Capabilities]   Renderer = Quadro FX 570/PCIe/SSE2
[osgEarth]  [Capabilities]   Version = 3.3.0
[osgEarth]  [Capabilities]   Max GPU texture units = 32
[osgEarth]  [Capabilities]   Max GPU texture coord indices = 8
[osgEarth]  [Capabilities]   Max GPU attributes = 16
[osgEarth]  [Capabilities]   Depth buffer bits = 24
[osgEarth]  [Capabilities]   Max texture size = 8192
[osgEarth]  [Capabilities]   Max lights = 8
[osgEarth]  [Capabilities]   GLSL = yes
[osgEarth]  [Capabilities]   GLSL Version = 330
[osgEarth]  [Capabilities]   Texture arrays = yes
[osgEarth]  [Capabilities]   3D textures = yes
[osgEarth]  [Capabilities]   Multitexturing = yes
[osgEarth]  [Capabilities]   draw instanced = yes
[osgEarth]  [Capabilities]   uniform buffer objects = yes
[osgEarth]  [Capabilities]   NPOT textures = yes
[osgEarth]  [Capabilities]   Texture buffers = yes
[osgEarth]  [Capabilities]   Texture buffer max size = 134217728
[osgEarth]  [Capabilities]   Transform feedback = no
[osgEarth]  [Capabilities]   Compression = ARB S3 RG
[osgEarth]  [Map] Map profile is: [srs=WGS 84, min=-180,-90 max=180,90 lod0=2,1 vdatum=geodetic]
[osgEarth]  [TerrainResources] Texture unit 0 reserved for MP Engine Primary
[osgEarth]  [TerrainResources] Texture unit 1 reserved for MP Engine Secondary
[osgEarth]  [MPTerrainEngineNode] Edge normalization is ON
[osgEarth]  [MapNode] Adding ellipsoid uniforms.
[osgEarth]  [MapNode] Added extension "viewpoints"
StatsHandler::StatsHandler() Setting up GL2 compatible shaders

C:\3rd_libs\OSG\OSG34_EARTH29_msvc2015\bin>osgearth_viewer ..\tests\arcgisonline.earth
_targetMaximumNumberOfPageLOD = 1000
[osgEarth]  [Map] cache=none; policy=read-write; bin=no
[osgEarth]  [TerrainLayer] Layer "arcgis-world-imagery" Creating "arcgis" driver
[osgEarth]  [TerrainLayer] Layer "arcgis-world-imagery" Profile=[srs=Mercator CS, min=-20037508.34278925,-20037508.34278925 max=20037508.34278925,20037508.34278925 lod0=1,1 vdatum=geodetic]
[osgEarth]  [TerrainLayer] Layer "arcgis-world-imagery" cache=none; policy=no-cache; bin=no
[osgEarth]  [engine_mp driver] Activated!
[osgEarth]  [Capabilities] osgEarth Version: 2.9.0
[osgEarth]  [Capabilities] Detected hardware capabilities:
[osgEarth]  [Capabilities]   Vendor = NVIDIA Corporation
[osgEarth]  [Capabilities]   Renderer = Quadro FX 570/PCIe/SSE2
[osgEarth]  [Capabilities]   Version = 3.3.0
[osgEarth]  [Capabilities]   Max GPU texture units = 32
[osgEarth]  [Capabilities]   Max GPU texture coord indices = 8
[osgEarth]  [Capabilities]   Max GPU attributes = 16
[osgEarth]  [Capabilities]   Depth buffer bits = 24
[osgEarth]  [Capabilities]   Max texture size = 8192
[osgEarth]  [Capabilities]   Max lights = 8
[osgEarth]  [Capabilities]   GLSL = yes
[osgEarth]  [Capabilities]   GLSL Version = 330
[osgEarth]  [Capabilities]   Texture arrays = yes
[osgEarth]  [Capabilities]   3D textures = yes
[osgEarth]  [Capabilities]   Multitexturing = yes
[osgEarth]  [Capabilities]   draw instanced = yes
[osgEarth]  [Capabilities]   uniform buffer objects = yes
[osgEarth]  [Capabilities]   NPOT textures = yes
[osgEarth]  [Capabilities]   Texture buffers = yes
[osgEarth]  [Capabilities]   Texture buffer max size = 134217728
[osgEarth]  [Capabilities]   Transform feedback = no
[osgEarth]  [Capabilities]   Compression = ARB S3 RG
[osgEarth]  [Map] Map profile is: [srs=WGS 84, min=-180,-90 max=180,90 lod0=2,1 vdatum=geodetic]
[osgEarth]  [TerrainResources] Texture unit 0 reserved for MP Engine Primary
[osgEarth]  [TerrainResources] Texture unit 1 reserved for MP Engine Secondary
[osgEarth]  [MPTerrainEngineNode] Edge normalization is ON
[osgEarth]  [MapNode] Adding ellipsoid uniforms.
StatsHandler::StatsHandler() Setting up GL2 compatible shaders

C:\3rd_libs\OSG\OSG34_EARTH29_msvc2015\bin>
marlinrowley marlinrowley
Reply | Threaded
Open this post in threaded view
|

Re: White Globe on OSGEarth 2.9

In reply to this post by Mike Metcalf
I had a similar problem but it was our firewall blocking.  We had just moved to osgEarth and I was running examples from the website and didn't know we had to change our port settings to allow access to URLs in the code.

If you had it running before 2.9, then it's definitely something else.
Mike Metcalf Mike Metcalf
Reply | Threaded
Open this post in threaded view
|

Re: White Globe on OSGEarth 2.9

Marlin,

Yeah, we've been running OSGEarth since before 2.4 I believe, since around 2012 or 2013, iirc. In this case it isn't our firewall. We still have older versions of our app that link to OSG 3.4.1 and OSGEarth 2.8 that can still access and render arcgisonline imagery.

Thanks for your input!
-mike
Mike Metcalf Mike Metcalf
Reply | Threaded
Open this post in threaded view
|

Re: White Globe on OSGEarth 2.9

In reply to this post by Mike Metcalf
All:

We've been digging into this issue and have found what we think was the source of the problem.

When we built either OSG 3.6 or OSGEarth 2.9 from source, our CMAKE failed to find PROJ.4, which, we believe, was probably optional. Without it, the arcgisonline driver apparently doesn't work.

There is some uncertainty about this, because we've also been in the process of moving from boost 1.66 to boost 1.67, from the Microsoft VS 2015 compiler to the VS 2017 compiler, from Qt 5.10.0 to Qt 5.10.1, and moving to building 64-bit targets instead of 32-bit targets, along with some other minor updates.

In the end, our arcgisonline drivers are now working well.

Many thanks to everyone who offered their help!
-mike
plevy plevy
Reply | Threaded
Open this post in threaded view
|

Re: White Globe on OSGEarth 2.9

Mike,

Glad you were able to track that down.  Moving from a 32bit VS 2015 to 64bit 2017 will all the dependencies is a big task but hopefully, you will not have to worry about it moving forward until your dev environment changes again

--
Paul Levy : Pelican Mapping


On Mon, May 7, 2018 at 4:04 PM Mike Metcalf [via osgEarth] <[hidden email]> wrote:
All:

We've been digging into this issue and have found what we think was the source of the problem.

When we built either OSG 3.6 or OSGEarth 2.9 from source, our CMAKE failed to find PROJ.4, which, we believe, was probably optional. Without it, the arcgisonline driver apparently doesn't work.

There is some uncertainty about this, because we've also been in the process of moving from boost 1.66 to boost 1.67, from the Microsoft VS 2015 compiler to the VS 2017 compiler, from Qt 5.10.0 to Qt 5.10.1, and moving to building 64-bit targets instead of 32-bit targets, along with some other minor updates.

In the end, our arcgisonline drivers are now working well.

Many thanks to everyone who offered their help!
-mike


If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/White-Globe-on-OSGEarth-2-9-tp7591829p7591841.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML