earth radius

classic Classic list List threaded Threaded
8 messages Options
Raphael Raphael
Reply | Threaded
Open this post in threaded view
|

earth radius

I would like to use your library in a simulation application : what is the graphical radius of the earth model (the scale between the WGS84 model and the graphical representation) ?
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: earth radius

Hi Raphael,

The globe model in osgEarth is using the WGS84 radius using the default osg::EllipsoidModel.  So, radius at equator is 6378137.0 and polar radius is 6356752.3142.

Let us know how things work out with your simulation!

Thanks!

Jason

On Sun, Feb 8, 2009 at 5:32 PM, Raphael (via Nabble) - No Reply <[hidden email]> wrote:
I would like to use your library in a simulation application : what is the graphical radius of the earth model (the scale between the WGS84 model and the graphical representation) ?



View message @ http://n2.nabble.com/earth-radius-tp2294686p2294686.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.


Raphael Raphael
Reply | Threaded
Open this post in threaded view
|

Re: earth radius

I see the earth ellipsoid in the application, but the texture is not updated when I zoom in. I guess this is because the application uses a 1/100000 scale.
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: earth radius

Hi Raphael,

I'm not sure I understand your issue.  If you just run osgviewer with one of the test earth files does everything behave correctly?  As I mentioned before, osgEarth uses the actual scale for the WGS84 ellipsoid, so there is no 1/100000 scale in osgEarth. 

If you are using a 1/100000 scale in your application, you might be able to stick a scaling MatrixTransform above the earth model in the scene graph to make it match your scale.  If you do that, I can see how perhaps that would throw off the PagedLOD system since it is set up to work at the actual scale.  You could maybe try changing the min tile range factor, which defaults to 8, to something like 0.00008.  You can try this by adding <min_tile_range_factor>0.0008</min_tile_range_factor> to the .earth file you are using.

Thanks!

Jason

On Mon, Feb 9, 2009 at 1:29 AM, Raphael (via Nabble) - No Reply <[hidden email]> wrote:
I see the earth ellipsoid in the application, but the texture is not updated when I zoom in. I guess this is because the application uses a 1/100000 scale.



View message @ http://n2.nabble.com/earth-radius-tp2294686p2295966.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.


Raphael Raphael
Reply | Threaded
Open this post in threaded view
|

Re: earth radius

Thank you for the answer,
The scale I was talking about was internal to the simulation application (not to osgEarth). I put a MatrixTransform scale node above osgEarth in the scenegraph, so it renders at the correct scale in my application. But the problem comes after that : the texture is "stucked" at the lowest LOD. What you say about setting "min_tile_range_factor" was promising but finally didn't work.

jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: earth radius

Hi Raphael,

You might also want to look at the setLODScale method of osg::Camera.  You can add a osgViewer::LODScaleHandler to your Viewer and see what happens if you decrease the LODScale.  You might be able to do something like viewer.getCamera()->setLODScale(1/100000).  I have no idea if that would work, but its worth a shot!

Good luck and keep us posted!

Jason

On Mon, Feb 9, 2009 at 11:35 AM, Raphael (via Nabble) - No Reply <[hidden email]> wrote:
Thank you for the answer,
The scale I was talking about was internal to the simulation application (not to osgEarth). I put a MatrixTransform scale node above osgEarth in the scenegraph, so it renders at the correct scale in my application. But the problem comes after that : the texture is "stucked" at the lowest LOD. What you say about setting "min_tile_range_factor" was promising but finally didn't work.




View message @ http://n2.nabble.com/earth-radius-tp2294686p2298121.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.


Raphael Raphael
Reply | Threaded
Open this post in threaded view
|

Re: earth radius

It finally works ! So nice :-)
It was a problem of database pager configuration (which was a bad custom one).
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: earth radius

Great!  Glad to hear it!

Sent from my iPhone

On Feb 9, 2009, at 4:34 PM, "Raphael (via Nabble) - No Reply" <[hidden email]> wrote:

It finally works ! So nice :-)
It was a problem of database pager configuration (which was a bad custom one).


View message @ http://n2.nabble.com/earth-radius-tp2294686p2299525.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.