i want to update fwtools, what do i have to do with osgearth?

classic Classic list List threaded Threaded
4 messages Options
christian_sam christian_sam
Reply | Threaded
Open this post in threaded view
|

i want to update fwtools, what do i have to do with osgearth?

hi

i have built osg and osgearth against fwtools-2.0.4. now i'm planning to install the latest fwtools version - what steps will i have to do referring osg and osgearth?

* does it suffice to update my %PATH% systemvariable from "...program files\fwtools2.0.4\bin;..." to "...program files\fwtools2.2.8\bin;..."?

* or do i have to run cmake for all my osg* libraries (update the gdal include/lib paths there), and run a new build process with the generated .sln file? if yes, do i have to clear any cmake caches or do a complete rebuild of osgearth?


thanks in advance,
christian
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: i want to update fwtools, what do i have to do with osgearth?

Never tried it. If the GDAL version has changed you might have to rebuild. Best advice I can give you is to just try it out and let us know ;) -gw

Glenn Waldron / Pelican Mapping
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: i want to update fwtools, what do i have to do with osgearth?

Hi Christian

You shouldn't need to rebuild OSG unless you are making use of the OSG Gdal plugin(which is different than the osgearth Gdal plugin).  I would recommend rebuilding the osgearth plugin though just to be on the safe side. 

Thanks!

Jason

On Mar 15, 2009, at 8:46 PM, "gwaldron (via Nabble)" <[hidden email]> wrote:

Never tried it. If the GDAL version has changed you might have to rebuild. Best advice I can give you is to just try it out and let us know ;) -gw

Glenn Waldron * Pelican Mapping * [hidden email] * +1 703 652 4791



View message @ http://n2.nabble.com/i-want-to-update-fwtools%2C-what-do-i-have-to-do-with-osgearth--tp2483535p2483601.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.

christian_sam christian_sam
Reply | Threaded
Open this post in threaded view
|

Re: i want to update fwtools, what do i have to do with osgearth?

hi,

i think i will stick at my old fwtools2.0.4 version, as far as i have seen there isn't any specific >=version requirement in osgearth or osg.

btw.
osg provides this osgdb gdal plugin, is this only a foundation on which gis specific extensions like osgearth or osggis build up, or can it be used directly for anything usefull in osg?


thanks in advance,
christian