osgEarth 1.1 : Graphic bug ?

classic Classic list List threaded Threaded
4 messages Options
Aurelien Aurelien
Reply | Threaded
Open this post in threaded view
|

osgEarth 1.1 : Graphic bug ?

Hello !

I switched this morning to osgEarth 1.1 (from 1.0)

It seems to work :



But with some "point of view" the geometry is broken, and drawing become extremly slow (about 10sec/frame !!!) :



I use a Nvidia Quadro FX 1700 graphic card, and this .earth file :

<map type="mercator">

        <image name="Google maps satellite imagery" driver="google">
                <dataset>satellite</dataset>
        </image>
       
</map>


Do you have any idea about this issue ?

Thanks !
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth 1.1 : Graphic bug ?

Hi Aurelien,

In 1.1 that could affect this are the fact that mercator datasources are now composited together and cropped to match a global-geodetic profile.  The MercatorLocator is then used to reproject the mercator image by providing the correct texture coordinates.  This allows you to mix geodetic and mercator datasources on the same globe.

However, this does require non power of two textures to be correctly supported on your hardware since the composited image will most likely be a npot texture.

One thing to note, map type ='mercator' doesn't do anything since that is not a supported "type" of map, so it just defaults to geocentric.

Some things to test:
1)  Try changing your map type to "flat".  That will use a standard mercator profile and draw a flat map.  Is that still quick?
2)  If after doing 1, your map is indeed still fast, try adding <profile>global-geodetic</profile> to your map element.  This will cause the reprojection but on a flat map.  I would bet that is still slow.
3)  See what happens if you disable non-power of 2 textures on your machine.  So set the environment variable to OSG_GL_EXTENSION_DISABLE=GL_ARB_texture_non_power_of_two.  This should cause OSG to resize the images when they are applied.  You might see some frame hiccups while the image is being resized, but you shoudln't be seeing 10 fps.

See what happens in those cases and we'll figure out where to go from there.

Thanks!

Jason

On Wed, Apr 29, 2009 at 5:50 AM, Aurelien (via Nabble) <[hidden email]> wrote:
Hello !

I switched this morning to osgEarth 1.1 (from 1.0)

It seems to work :



But with some "point of view" the geometry is broken, and drawing become extremly slow (about 10sec/frame !!!) :



I use a Nvidia Quadro FX 1700 graphic card, and this .earth file :

<map type="mercator">

        <image name="Google maps satellite imagery" driver="google">
                <dataset>satellite</dataset>
        </image>
       
</map>


Do you have any idea about this issue ?

Thanks !


View message @ http://n2.nabble.com/osgEarth-1.1-%3A-Graphic-bug---tp2739678p2739678.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.


Aurelien Aurelien
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth 1.1 : Graphic bug ?

Hi.

I've tested your suggestions... but no change !

It's still very slow (not 10fps, but 10 secondes per frame sometimes !!!) and I still have "geometry errors" like on the screen shots.

Using OSG_GL_EXTENSION_DISABLE=GL_ARB_texture_non_power_of_two resize the texture as well (I see it in the console) but nothing changed.

I've switch back to 1.0.

Thanks for your help.
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth 1.1 : Graphic bug ?

Hi Aurelien,

Does an example like the metacarta_wms.earth work fine?  Are you only seeing this issue with Mercator sources?  Do you see the same behavior with the yahoo_aerial.earth example?

Also, does this problem only occur in your application or does it also occur when you run the .earth file via osgviewer?

Thanks,

Jason

On Wed, May 6, 2009 at 3:44 AM, Aurelien (via Nabble) <[hidden email]> wrote:
Hi.

I've tested your suggestions... but no change !

It's still very slow (not 10fps, but 10 secondes per frame sometimes !!!) and I still have "geometry errors" like on the screen shots.

Using OSG_GL_EXTENSION_DISABLE=GL_ARB_texture_non_power_of_two resize the texture as well (I see it in the console) but nothing changed.

I've switch back to 1.0.

Thanks for your help.


View message @ http://n2.nabble.com/osgEarth-1.1-%3A-Graphic-bug---tp2739678p2809037.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.