osgEarth 2.9 cache_only problem with arcgisonline.test

classic Classic list List threaded Threaded
8 messages Options
DC DC
Reply | Threaded
Open this post in threaded view
|

osgEarth 2.9 cache_only problem with arcgisonline.test

If I cache data from running arcgisonline.earth with the cache policy set to read_write and then run with the cache policy set to cache_only, I see some black and white tiles. I don't see this with the cache policy set to read_write. Attached 2 screen shots.

This is a fresh cache and not mixed with any previous versions. osgEarth is linked to osgversion 3.6.2.

I don't see this happening with readymap.earth.

Thanks.
DC


plevy plevy
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth 2.9 cache_only problem with arcgisonline.test

DC,

I quickly cached some imagery down to the ground level and I do not see the black bars.  

Can you tell me more about your setup, what specific version of osgearth, the osgearth-2.9 tag? Have you also tried master?

How are you caching the imagery so I can try to reproduce what you are doing to see the problem?

Thank you
--
Paul Levy


On Thu, Sep 13, 2018 at 6:24 PM DC [via osgEarth] <[hidden email]> wrote:
If I cache data from running arcgisonline.earth with the cache policy set to read_write and then run with the cache policy set to cache_only, I see some black and white tiles. I don't see this with the cache policy set to read_write. Attached 2 screen shots.

This is a fresh cache and not mixed with any previous versions. osgEarth is linked to osgversion 3.6.2.

I don't see this happening with readymap.earth.

Thanks.
DC





If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgEarth-2-9-cache-only-problem-with-arcgisonline-test-tp7592008.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML
plevy plevy
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth 2.9 cache_only problem with arcgisonline.test

I think I have it, you are using mp terrain engine and I was using rex.  I also see the problem using the current osgearth but can you try running with rex instead?
set OSGEARTH_TERRAIN_ENGINE=rex

Thank you



On Fri, Sep 14, 2018 at 12:31 PM plevy [via osgEarth] <[hidden email]> wrote:
DC,

I quickly cached some imagery down to the ground level and I do not see the black bars.  

Can you tell me more about your setup, what specific version of osgearth, the osgearth-2.9 tag? Have you also tried master?

How are you caching the imagery so I can try to reproduce what you are doing to see the problem?

Thank you
--
Paul Levy


On Thu, Sep 13, 2018 at 6:24 PM DC [via osgEarth] <[hidden email]> wrote:
If I cache data from running arcgisonline.earth with the cache policy set to read_write and then run with the cache policy set to cache_only, I see some black and white tiles. I don't see this with the cache policy set to read_write. Attached 2 screen shots.

This is a fresh cache and not mixed with any previous versions. osgEarth is linked to osgversion 3.6.2.

I don't see this happening with readymap.earth.

Thanks.
DC





If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgEarth-2-9-cache-only-problem-with-arcgisonline-test-tp7592008.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML



If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgEarth-2-9-cache-only-problem-with-arcgisonline-test-tp7592008p7592015.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML
DC DC
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth 2.9 cache_only problem with arcgisonline.test

In reply to this post by plevy
Paul,

I am using the osgEarth-29 tag. I have not tried it with the master.

I modified the arcgisonline.earth file to cache by adding this to the options tag:

<cache_policy usage="read_write"/>
    <cache type="filesystem">
     <path>../earth-cache</path>
</cache>

That is the only change I made.

After caching, I run with "cache_only" and see the anomaly.

Thanks,
DC
DC DC
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth 2.9 cache_only problem with arcgisonline.test

In reply to this post by plevy
Paul,

I just saw your latest post. I'll try using OSGEARTH_TERRAIN_ENGINE=rex on Monday and let you know the results.

Thank you.
DC
DC DC
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth 2.9 cache_only problem with arcgisonline.test

In reply to this post by plevy
Paul,

WIth the example arcgisonline.earth file, using rex engine works correctly for me with cache only.

Thanks.
DC DC
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth 2.9 cache_only problem with arcgisonline.test

In reply to this post by plevy
Paul,

The arcgisonline.earth runs well with cache_only using rex engine. Is there any chance to see what is wrong with cache_only with the mp engine? I am having a hard time using rex engine with our application. I haven't tracked it down yet, but the screen is black and mouse movements don't work.

Thanks,
DC
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth 2.9 cache_only problem with arcgisonline.test

Gents,
I located the problem. It's the MP "mercator fast path" code. It does not work correctly with the cache. I am going to disable this feature by default in MP -- there's not much point in trying to fix it now in the legacy engine.
Glenn Waldron / Pelican Mapping