osgEarth from ubuntu package not seeing GEOS

classic Classic list List threaded Threaded
3 messages Options
krzysief krzysief
Reply | Threaded
Open this post in threaded view
|

osgEarth from ubuntu package not seeing GEOS

Hi,
 My code has to use GEOS features through osgEarth API, unfortunately I got the
[osgEarth]* [Geometry] Crop failed - GEOS not available error and the app crashes.

I have the osgearth 2.9 from apt-get install on Ubuntu 18.04. I also have all the GEOS (3.6.2) libraries.

I cannot use cmake to build it locally from sources, is there any way to make the osgearth "see" this optional dependency?
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth from ubuntu package not seeing GEOS

GEOS is a compile-time dependency and it sounds like the 2.9 from apt-get was not built against GEOS. Not much you do about it now unfortunately, aside from building osgEarth yourself. I'm sorry, but we do not maintain the apt-get build.
Glenn Waldron / Pelican Mapping
krzysief krzysief
Reply | Threaded
Open this post in threaded view
|

Re: osgEarth from ubuntu package not seeing GEOS

Ah, so I'll have to build it locally, thank you very much!