Quantcast

osgearth_cache - sid not recognized

classic Classic list List threaded Threaded
3 messages Options
bclay bclay
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

osgearth_cache - sid not recognized

I am running into a problem trying to seed a cache.  when I run osgearth_cache on my earth file it complains about all of the MrSid files indicating that they are "not a recognized file format"  yet the same file display in our application when we run against the same earth file.  I tried running in the osgearth binary fdirectory and I tried copying osgearth_cache into my application directory and both methods give the same result.  Additionally processing one of the sid files gave another error message "Failed to build VRT from input dataset.  The gdal_MrSID.dll is in the directory with the executable as well as a subdirectory "gdalplugins"


Bruce
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: osgearth_cache - sid not recognized

Hi Bruce,

That's odd, could it be that a different version of GDAL is somehow getting into your path when you're running osgearth_cache?  Or maybe your application is setting some environment variables on startup that you're not setting in your command line?

Also, on Windows at least, I typically have to set my GDAL_DRIVER_PATH environment variable to the directory where the plugins are for them to be recognized.

Jason

On Wed, Feb 8, 2017 at 11:11 AM Bruce [via osgEarth] <[hidden email]> wrote:
I am running into a problem trying to seed a cache.  when I run osgearth_cache on my earth file it complains about all of the MrSid files indicating that they are "not a recognized file format"  yet the same file display in our application when we run against the same earth file.  I tried running in the osgearth binary fdirectory and I tried copying osgearth_cache into my application directory and both methods give the same result.  Additionally processing one of the sid files gave another error message "Failed to build VRT from input dataset.  The gdal_MrSID.dll is in the directory with the executable as well as a subdirectory "gdalplugins"


Bruce


If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgearth-cache-sid-not-recognized-tp7590459.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML
bclay bclay
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: osgearth_cache - sid not recognized

Jason
  Thanks for your reply.

I tried setting the GDAL_DRIVER_PATH as you suggested but I get the same result.  We typically do not set environment variables in/for our application because the users don't always have permissions to do so when they get our software.

I hope to start a full upgrade of all our support libraries this week using the CMAKE bundle that was posted.  Hopefully the will resolve the issue.

If you have any other suggestions I would be glad to try them.

Brue
Loading...