osgearth_viewer does not display the map

classic Classic list List threaded Threaded
3 messages Options
garbart garbart
Reply | Threaded
Open this post in threaded view
|

osgearth_viewer does not display the map

This post was updated on .
Hello everyone! I'm trying to run .earth file next content on MacOS using osgearth_viewer, but only get the white ball, no map. If I enable lighting the lighting are added, so the file is read and parsed. At the same time, if I run the same file using osgearth_viewer on Xubuntu 18.04, then everything works fine. What could be the problem?

<map name="OpenStreetMap" type="geocentric" version="2">
        <image name="osm_mapnik" driver="xyz">
                <url>http://[abc].tile.openstreetmap.org/{z}/{x}/{y}.png</url>
                <cache_policy usage="read_write"/>
        </image>

        <options>
                <cache driver="filesystem">
                        <path>/tmp/osge</path>
                </cache>
                <lighting>false</lighting>
        </options>
</map>




osgEarth 2.10.0
osg 3.6.0
GDAL 2.3.0
curl 7.54.0
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: osgearth_viewer does not display the map

Garbart,
The XYZ driver receives no metadata from the server, so it does not know the profile of the map data. You have to tell it. Add this to the image element:

<profile>spherical-mercator</profile>

I'm surprised that you didn't get a console warning message. Do you have notifications disabled?

Glenn Waldron / Pelican Mapping
garbart garbart
Reply | Threaded
Open this post in threaded view
|

Re: osgearth_viewer does not display the map

Hello.

I tried adding a line like you said, but it didn't work. I'm still getting the white ball. I get some error messages, but I don't understand what they mean :(

I attach a file with the output of the console.

terminal.txt