osgearth2.9 build issue

classic Classic list List threaded Threaded
8 messages Options
jay jay
Reply | Threaded
Open this post in threaded view
|

osgearth2.9 build issue

Hello,

I tried to build 2.9 version with osg3.6 . i am getting error in xmemory() file "can not convert from std::pair <const _Kty, _Ty> to _ObjTy


pls help.


regards,
Jai
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: osgearth2.9 build issue

What compiler are you using?

On Mon, Sep 24, 2018 at 6:16 AM jay [via osgEarth] <[hidden email]> wrote:
Hello,

I tried to build 2.9 version with osg3.6 . i am getting error in xmemory() file "can not convert from std::pair <const _Kty, _Ty> to _ObjTy


pls help.


regards,
Jai


If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgearth2-9-build-issue-tp7592035.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML
jay jay
Reply | Threaded
Open this post in threaded view
|

Re: osgearth2.9 build issue

Visual studio  professional 2017

On Mon, 24 Sep 2018, 21:56 jasonbeverage [via osgEarth], <[hidden email]> wrote:
What compiler are you using?

On Mon, Sep 24, 2018 at 6:16 AM jay [via osgEarth] <[hidden email]> wrote:
Hello,

I tried to build 2.9 version with osg3.6 . i am getting error in xmemory() file "can not convert from std::pair <const _Kty, _Ty> to _ObjTy


pls help.


regards,
Jai


If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgearth2-9-build-issue-tp7592035.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML



If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgearth2-9-build-issue-tp7592035p7592037.html
To unsubscribe from osgearth2.9 build issue, click here.
NAML
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: osgearth2.9 build issue

Not sure what the issue might be.  We build VS 2017 continuously using appveyor (and also on own own dev machines) and haven't had any issues.

On Mon, Sep 24, 2018 at 12:27 PM jay [via osgEarth] <[hidden email]> wrote:
Visual studio  professional 2017

On Mon, 24 Sep 2018, 21:56 jasonbeverage [via osgEarth], <[hidden email]> wrote:
What compiler are you using?

On Mon, Sep 24, 2018 at 6:16 AM jay [via osgEarth] <[hidden email]> wrote:
Hello,

I tried to build 2.9 version with osg3.6 . i am getting error in xmemory() file "can not convert from std::pair <const _Kty, _Ty> to _ObjTy


pls help.


regards,
Jai


If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgearth2-9-build-issue-tp7592035.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML



If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgearth2-9-build-issue-tp7592035p7592037.html
To unsubscribe from osgearth2.9 build issue, click here.
NAML



If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgearth2-9-build-issue-tp7592035p7592038.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML
remoe remoe
Reply | Threaded
Open this post in threaded view
|

Re: osgearth2.9 build issue

In reply to this post by jay
Hi

I don't have any build issues with latest osgEarth master, OSG 3.6.3 and VStudio 2017 15.8.2

Cheers,
Remo Eichenberger, Switzerland
jay jay
Reply | Threaded
Open this post in threaded view
|

Re: osgearth2.9 build issue

It is showing issue in memoryx file where visual studio is installed. 

On Tue, 25 Sep 2018, 18:55 remoe [via osgEarth], <[hidden email]> wrote:
Hi

I don't have any build issues with latest osgEarth master, OSG 3.6.3 and VStudio 2017 15.8.2

Cheers,
Remo Eichenberger, Switzerland



If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgearth2-9-build-issue-tp7592035p7592042.html
To unsubscribe from osgearth2.9 build issue, click here.
NAML
jasonbeverage jasonbeverage
Reply | Threaded
Open this post in threaded view
|

Re: osgearth2.9 build issue

Jay grab the master, this was fixed in there but not in 2.9.  We're hoping to do a 2.10 soon so the fix will be in there along with a whole host of other goodies.

Thanks,

Jason

On Tue, Sep 25, 2018 at 9:28 AM jay [via osgEarth] <[hidden email]> wrote:
It is showing issue in memoryx file where visual studio is installed. 

On Tue, 25 Sep 2018, 18:55 remoe [via osgEarth], <[hidden email]> wrote:
Hi

I don't have any build issues with latest osgEarth master, OSG 3.6.3 and VStudio 2017 15.8.2

Cheers,
Remo Eichenberger, Switzerland



If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgearth2-9-build-issue-tp7592035p7592042.html
To unsubscribe from osgearth2.9 build issue, click here.
NAML



If you reply to this email, your message will be added to the discussion below:
http://forum.osgearth.org/osgearth2-9-build-issue-tp7592035p7592043.html
To start a new topic under osgEarth, email [hidden email]
To unsubscribe from osgEarth, click here.
NAML
jay jay
Reply | Threaded
Open this post in threaded view
|

Re: osgearth2.9 build issue

HI Jason,

I grabbed master, but using that facing 5603 error mainly related to unresolved external symbol in  many object file like osgeath_lights.obj, osgearth_featuresinfo.obj


regards
Jai