Quantcast

problem about the texture of model

classic Classic list List threaded Threaded
4 messages Options
hawayii hawayii
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

problem about the texture of model

hi
    in my osgEarth application, there is a building with lots of windows(texture).
    my problem is that the windows become vague when the camera is far from the building, but i do not want to the effect.
    i think the reason is about lod or sampling. So i want to know that are there some ways to disable this effect.


thanks
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem about the texture of model

hawayii,

If you are creating buildings as in boston.earth, you don't have any control over the texture filtering (which might be what you are talking about). It is hard-coded in osgEarth. You may need to write custom code to change the filtering.
Glenn Waldron / Pelican Mapping / @glennwaldron
hawayii hawayii
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem about the texture of model

hi

    i load the buildings by using simple model driver.
    are there some properties to control the texture filtering.

thanks
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem about the texture of model

Not in osgEarth. You would need to change these on the model itself. Look to the osg::Texture::setFilter() function.
Glenn Waldron / Pelican Mapping / @glennwaldron
Loading...