problem of integrating triton with osgearth

classic Classic list List threaded Threaded
7 messages Options
pskpg pskpg
Reply | Threaded
Open this post in threaded view
|

problem of integrating triton with osgearth

Hello,

I am using a local bathymetry data to run the osgearth_triton. But I can't get a correct ocean result. The image shows the error. What should I do?

Thx very much!

gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: problem of integrating triton with osgearth

Please post the output of:
osgearth_version --caps
Glenn Waldron / Pelican Mapping
pskpg pskpg
Reply | Threaded
Open this post in threaded view
|

Re: problem of integrating triton with osgearth

Thanks for reply. This is the screenshot:
pskpg pskpg
Reply | Threaded
Open this post in threaded view
|

Re: problem of integrating triton with osgearth

In reply to this post by gwaldron
My computer has two graphics cards: Intel(R) HD Graphics 630 and NVDIA GeForce GTX 1050. But the capability output only display the Intel card. I've just updated the drive program a few days ago. Perhaps the drive version is not right. Let me check the driver again.
pskpg pskpg
Reply | Threaded
Open this post in threaded view
|

Re: problem of integrating triton with osgearth

In reply to this post by pskpg
I've updated the NVDIA GEFORCE GTX 1050's driver. But the osgearth_version --caps cmd still doesn't display this card. I guess something must be wrong with my hardware
gwaldron gwaldron
Reply | Threaded
Open this post in threaded view
|

Re: problem of integrating triton with osgearth

Check the NVIDIA control panel and see if you can force the use of the NVIDIA. There might be something in the BIOS as well.
Glenn Waldron / Pelican Mapping
pskpg pskpg
Reply | Threaded
Open this post in threaded view
|

Re: problem of integrating triton with osgearth

Haha, I've solved this through the NVDIA control panel! I selected the NVDIA card as the primary 3d card. And now the ocean runs well!
Thank you, again!